【POJ-1458】解题报告(DP,最长相同子序列)

原始题目

Common Subsequence

  • Time Limit: 1000MS
  • Memory Limit: 10000K
  • Total Submissions: 56895
  • Accepted: 23740

Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0

Source

Southeastern Europe 2003

题目大意

给定两个字符串,求最长相同子序列的长度。

解题思路

入门dp,状态转移方程为:dp[i][j]={dp[i-1][j-1]+1(a[i]=a[j]), max(dp[i-1][j],dp[i][j-1])(a[i]!=a[j]}

解题代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31

#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn=1005;
int len1,len2;
char s1[maxn],s2[maxn];
int dp[maxn][maxn];
void solve()
{
for(int i=0;i<len1;i++)
{
for(int j=0;j<len2;j++)
{
if(s1[i]==s2[j]) dp[i][j]=dp[i-1][j-1]+1;
else dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
}
}
}
int main()
{
while(~scanf("%s%s",s1,s2))
{
memset(dp,0,sizeof(dp));
len1=strlen(s1),len2=strlen(s2);
solve();
printf("%d\n",dp[len1-1][len2-1]);
}
return 0;
}

收获与反思

熟悉格式。