【ZOJ-1709】解题报告(BFS)

原始题目

Oil Deposits

  • Time Limit: 2 Seconds
  • Memory Limit: 65536 KB

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 ≤ m ≤ 100 and 1 ≤ n ≤ 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either '*', representing the absence of oil, or '@', representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

Source

Mid-Central USA 1997

题目大意

给定一个用*和@标记的油田,找出不连续的油田总数。

解题思路

每一个点入口 BFS,搜索过的标记,最后记录广搜的总次数就行。

解题代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
#include <queue>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#define maxn 105
using namespace std;
char map[maxn][maxn];//图
int n,m;//n为行数,m为列数
bool vis[maxn][maxn]; // 访问标记
//int dir[4][2]={0,1,0,-1,1,0,-1,0}; // 方向向量
int dir[8][2]={{1,1},{1,0},{1,-1},{0,1},{0,-1},{-1,1},{-1,0},{-1,-1}} ;
struct State // BFS 队列中的状态数据结构
{
int x,y; // 坐标位置
int Step_Counter; // 搜索步数统计器
};

State a[maxn];

bool CheckState(State s) // 约束条件检验
{
if(s.x>=0&&s.x<m&&s.y>=0&&s.y<n&&map[s.x][s.y]&&!vis[s.x][s.y]) // 满足条件
{
// printf("next %d %d\n",s.x,s.y);
return 1;
}
else // 约束条件冲突
return 0;
}

void bfs(State st)
{
queue <State> q; // BFS 队列
State now,next; // 定义2个状态,当前和下一个
st.Step_Counter=0; // 计数器清零
q.push(st); // 入队
vis[st.x][st.y]=1; // 访问标记
while(!q.empty())
{
now=q.front(); // 取队首元素进行扩展
// if(now==G) // 出现目标态,此时为Step_Counter 的最小值,可以退出即可
// {
// ...... // 做相关处理
// return;
// }
for(int i=0;i<8;i++)
{
next.x=now.x+dir[i][0]; // 按照规则生成 下一个状态
next.y=now.y+dir[i][1];
// printf("insert %d %d\n",next.x,next.y);
next.Step_Counter=now.Step_Counter+1; // 计数器加1
if(CheckState(next)) // 如果状态满足约束条件则入队
{
q.push(next);
// printf("insert %d %d\n",next.x,next.y);
vis[next.x][next.y]=1; //访问标记
}
}
q.pop(); // 队首元素出队
}
return;
}

int main()
{
while(~scanf("%d%d",&m,&n)&&m+n)
{
memset(vis,0,sizeof(vis));
for(int i=0;i<m;i++)
{
scanf("%s",map[i]);
for(int j=0;j<n;j++)
{
if(map[i][j]=='*') map[i][j]=0;
else if(map[i][j]=='@') map[i][j]=1;
}
}
int count=0;
for(int i=0;i<m;i++)
{
for(int j=0;j<n;j++)
{
if(map[i][j]&&!vis[i][j]) //此区域有油&&没有被访问过
{
count++;
State curst;
curst.x=i;curst.y=j;
// printf("search %d %d\n",i,j);
bfs(curst);//BFS搜索
}
}
}
printf("%d\n",count);
}
return 0;
}

收获与反思

第一次使用模板,对于这种图表示的还比较顺手,如何按照规则查找出下一个状态是广搜的关键。

PS:注意一些细节,比如 1 和 i 的区别,一点打错了要 debug 半天真的伤不起啊。