【HDU-1754】解题报告(线段树最大值,点维护)

原始题目

I Hate It

  • Time Limit: 9000/3000 MS (Java/Others)
  • Memory Limit: 32768/32768 K (Java/Others)
  • Total Submission(s): 92291
  • Accepted Submission(s): 35036

Problem Description

很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。 这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。

Input

本题目包含多组测试,请处理到文件结束。 在每个测试的第一行,有两个正整数 N 和 M ( 0<N≤200000,0<M<5000 ),分别代表学生的数目和操作的数目。 学生ID编号分别从1编到N。 第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。 接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。 当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。 当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。

Output

对于每一次询问操作,在一行里面输出最高成绩。

Sample Input

5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5

Sample Output

5
6
5
9

Hint

Huge input,the C function scanf() will work better than cin

Author

linle

Source

2007省赛集训队练习赛(6)_linle专场

Recommend

lcy

题目大意

如中文

#解题思路

线段树模板题,点修改,维护最大值

#解题代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cmath>
#include <iostream>
#include <iomanip>
#include <string>
#include <set>
#include <queue>
#include <vector>
#include <map>
using namespace std;
const int maxn=2e5+5;

int n,m;
int d,x;
int a[maxn];
struct node
{
int l;
int r;
int maxnum;
}tree[maxn<<2];

char ch[2];

void build(int k,int l,int r) //k为线段树的角标
{
tree[k].l=l;
tree[k].r=r;
if(l==r)
{
tree[k].maxnum=a[l]=a[r]; //叶子节点,单点的max值就是该点的值
return ;
}
int mid=(l+r)>>1;
build(k<<1,l,mid); //递归构建左线段(左子树)
build(k<<1|1,mid+1,r); //递归构建右线段(右子树)
tree[k].maxnum=max(tree[k<<1].maxnum,tree[k<<1|1].maxnum); //根节点的最大值是左右子树最大值的max
return ;
}

void change(int k,int d,int x)
{
if(tree[k].l==tree[k].r&&tree[k].r==d) //找到索引点
{
tree[k].maxnum=x; //修改最大值
return ;
//修改后再开始回溯
}
int mid=(tree[k].l+tree[k].r)>>1;
if(d>=tree[k].l&&d<=mid) //查找点在左子树
change(k<<1,d,x); //k<<1为左子树,
else //查找点在右子树,
change(k<<1|1,d,x); //k<<1|1为右子树
tree[k].maxnum=max(tree[k<<1].maxnum,tree[k<<1|1].maxnum); //递归从新计算非叶结点的值
}


int query(int k,int l,int r)
{
int maxnum;
if(tree[k].l==l&&tree[k].r==r)
return tree[k].maxnum;
int mid=(tree[k].l+tree[k].r)>>1;
if(r<=mid)
maxnum=query(k<<1,l,r);
else if(l>=mid+1)
maxnum=query(k<<1|1,l,r);
else
maxnum=max(query(k<<1,l,mid),query(k<<1|1,mid+1,r)); //中线跨区间
return maxnum;
}


int main()
{
while(~scanf("%d%d",&n,&m))
{
memset(tree,0,sizeof(tree));
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
}
build(1,1,n);
for(int i=1;i<=m;i++)
{
scanf("%s%d%d",ch,&d,&x);

if(ch[0]=='Q') //查询输入
{
printf("%d\n",query(1,d,x));
}
else
change(1,d,x);
}
}
}

收获与反思

  • 对模板的理解都写在注释里了
  • 本题是维护最大值,可以用int替换ll
  • 切记memset数组