【HDU-1027】解题报告(排列STL)

原始题目

Ignatius and the Princess II

  • Time Limit: 2000/1000 MS (Java/Others)
  • Memory Limit: 65536/32768 K (Java/Others)
  • Total Submission(s): 9305
  • Accepted Submission(s): 5446

Problem Description

Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......" Can you help Ignatius to solve this problem?

Input

The input contains several test cases. Each test case consists of two numbers, \(N\) and \(M\) (1 N 1000, 1 M 10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.

Output

For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.

Sample Input

6 4
11 8

Sample Output

1 2 3 5 6 4
1 2 3 4 5 6 7 9 8 11 10

Author

Ignatius.L

题目大意

定义排列逆序,输出对应编号的排列

解题思路

利用C++STL中的next_permutation()函数实现对数组排列,调用m-1次该函数然后按格式输出即可。

解题代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
#include <iostream> 
#include <algorithm>
#include <string>
#include <stack>
#include <vector>
#define maxn 100010
using namespace std;
int a[maxn];
int main()
{
int n,m;
while(cin>>n>>m)
// cin>>n>>m;
{
for(int i=0;i<n;i++)
{
a[i]=i+1;
}
// vector<int> v1(a,a+n); 没有利用上vector 待补充
// vector<int>::iterator p=v1.begin();
int count=m-1; //设置计数器
do //注意使用dowhile
{
// for(int j=0;j<n;j++)
// cout<<a[j]<<" ";
// cout<<endl;
count--;
}while(next_permutation(a,a+n)&&count);
for(int j=0;j<n-1;j++)
cout<<a[j]<<" ";
cout<<a[n-1]<<endl; //输出格式最后一个数后面没有空格
}
return 0;
}

收获与反思

图片待添加