【CSU-2158】解题报告(水题)

原始题目

2158: 长门的运动会

  • Time Limit: 1 Sec
  • Memory Limit: 128 Mb
  • Submitted: 2
  • Solved: 2
  • SpecialJudge

Description

运动会,好开心~

CSU (California State University) 正在举行一场特殊的接力跑比赛,比赛在环形跑道上进行,同一支队伍的所有人从同一个位置向相同的方向出发,当需要接力的两个人再次相遇时,他们就要交接棒。最后总成绩是以队伍跑的总路程计算的

1.png
1.png

现在接力的第一棒在Nagato手中,需要把它交给Kyon。在长度为C的环形跑道上,他们出发了!Nagato以速度A匀速跑动,Kyon以速度B匀速跑动。他们在经过多长时间后可以再次相遇?

Input

多组数据,第一行为一个整数T (1 ≤ T ≤ 106),表示数据组数。

之后每行是一组数据,有三个整数C, A, B (1 ≤ C, A, B ≤ 109, A ≠ B),分别表示环形跑道的长度,Nagato的速度和Kyon的速度。

Output

每行输出一个数,表示再次相遇所需的时间。绝对误差或相对误差小于10−5则认为是正确的。

Sample Input

2
3 1 2
5 10 7

Sample Output

3.00000000
1.66666667

Hint

Source

Author

Yuki Nagato

题目大意

如题

解题思路

水题,追击运动一圈

解题代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
#include <cstdio>
#include <cstring>
#include <iostream>
#include <iomanip>
#include <cmath>
#include <sstream>
#include <set>
#include <vector>
#include <stack>
#include <queue>
#include <map>
#include <algorithm>
#define rep(i,a,n) for(int i=a;i<n;++i)
#define per(i,a,n) for(int i=n-1;i>=a;--i)
#define ms(x,a) memset((x),a,sizeof(x))
#define pb push_back
#define np next_permutation
#define mp make_pair
#define INF 0x3f3f3f3f
#define eps 1e-8
#define all(x) x.begin(),x.end()
#define ins(x) inserter(x,x.begin())
#define mod 1000000005
#define K 20
using namespace std;
const int maxn=1e2+5;
const int maxl=26;
const int maxm=1e5+5;
typedef long long ll;
ll t,n,a;
int c[K];
int main(){
scanf("%lld",&t);
while(t--){
int a,b,c;
scanf("%d%d%d",&a,&b,&c);
if(b<c) swap(b,c);
double ans=double(a)/(b-c);
printf("%f\n",ans);
}
}

收获与反思

水题