【POJ-1611】解题报告(并查集)

原始题目

The Suspects

  • Time Limit: 1000MS
  • Memory Limit: 20000K
  • Total Submissions: 51885
  • Accepted: 24803

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). Once a member in a group is a suspect, all members in the group are suspects. However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

Source

Asia Kaohsiung 2003

题目大意

为了减少SARS传播,最好的方法是将这些疑似患者区分开。现在给定一个学校里有\(n\)个人,\(m\)个学生团体, 同一学生团体中只要有一个疑似患者,即都被认定为疑似患者。现在统计所有的疑似患者的数量。

解题思路

标准并查集,维护一个数组cnt记录集合的大小,根节点的cnt值为集合大小。

初始化

fa[i]=i; 
cnt[i]=1; 

find函数路径压缩

fa[x]=find(fa[x]);  //加速下一次询问

merge函数增加维护cnt

cnt[fx] += cnt[fy]

解题代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
#include <cstdio>
#include <cstring>
#include <iostream>
#include <set>
#include <queue>
#include <vector>
#include <stack>
#include <vector>
#include <algorithm>
#include <string>
#include <iostream>
#include <iomanip>
using namespace std;
const int maxn=1e5+5;
const int maxm=1e5+5;


typedef long long ll;
typedef unsigned long long ull;
typedef vector<int> vi;
typedef pair<int,int> pii;
typedef pair<string,string> pss;


#define rep(i,a,n) for(int i=a;i<n;++i)
#define per(i,a,n) for(int i=n-1;i>=a;--i)
#define cl(x,a) memset(x,a,sizeof(x))
#define pb push_back
#define np next_permutation
#define mp make_pair
#define INF 0x3f3f3f3f
#define EPS 1e-8

int fa[maxn],cnt[maxn];
int n,m,k;
void init(int n){
rep(i,0,n){
fa[i]=i;
cnt[i]=1;
}
}

int find(int x){
if(fa[x]==x) return x;
else {
fa[x]=find(fa[x]);
return fa[x];
}
}

bool merge(int x,int y){
int fx=find(x),fy=find(y);
if(fx==fy) return false;
else {
fa[fy]=fx;
cnt[fx]+=cnt[fy];
return true;
}
}

int check(int x){
return cnt[find(x)];
}




int main(){
ios::sync_with_stdio(false);
while(cin>>n>>m && n+m){
init(n);
rep(i,0,m){
cin>>k;
int first,temp;
cin>>first;
rep(t,1,k){
cin>>temp;
merge(first,temp);
}

}
// cout<<"#";
cout<<check(0)<<endl;
}
}

收获与反思

待补充