【HDU-3172】解题报告(并查集)

原始题目

Virtual Friends

  • Time Limit: 4000/2000 MS (Java/Others)
  • Memory Limit: 32768/32768 K (Java/Others)
  • Total Submission(s): 11465
  • Accepted Submission(s): 3345

Problem Description

These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends' friends, their friends' friends' friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends.

Your task is to observe the interactions on such a website and keep track of the size of each person's network.

Assume that every friendship is mutual. If Fred is Barney's friend, then Barney is also Fred's friend.

Input

Input file contains multiple test cases.

The first line of each case indicates the number of test friendship nest.

Each friendship nest begins with a line containing an integer F, the number of friendships formed in this frindship nest, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase).

Output

Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.

Sample Input

1
3
Fred Barney
Barney Betty
Betty Wilma

Sample Output

2
3
4

Source

University of Waterloo Local Contest 2008.09

Recommend

chenrui

题目大意

朋友圈,给出\(n\)组朋友,每次输入两个人名,表示两个人成为朋友,同时输出当下两个人朋友圈的总大小。

解题思路

  • 利用map(unordered_map)存储string->int的映射。
  • 标准并查集,维护集合的大小。
  • 每次merge两人所代表的集合,输出大小即可。

解题代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
#include <cstdio>
#include <cstring>
#include <iostream>
#include <set>
#include <queue>
#include <vector>
#include <stack>
#include <vector>
#include <algorithm>
#include <string>
#include <iostream>
#include <iomanip>
#include <map>
#include <unordered_map>
using namespace std;
const int maxn=1e5+5;
const int maxm=1e5+5;


typedef long long ll;
typedef unsigned long long ull;
typedef vector<int> vi;
typedef pair<int,int> pii;
typedef pair<string,string> pss;


#define rep(i,a,n) for(int i=a;i<n;++i)
#define per(i,a,n) for(int i=n-1;i>=a;--i)
#define cl(x,a) memset(x,a,sizeof(x))
#define pb push_back
#define np next_permutation
#define mp make_pair
#define INF 0x3f3f3f3f
#define EPS 1e-8
unordered_map <string,int> mmp;
int fa[maxn],cnt[maxn];
int n,m,k,t;
void init(){
rep(i,0,maxn){
fa[i]=i;
cnt[i]=1;
}
mmp.clear();
}

int find(int x){
if(fa[x]==x) return x;
else {
fa[x]=find(fa[x]);
return fa[x];
}
}

bool merge(int x,int y){
int fx=find(x),fy=find(y);
if(fx==fy) return false;
else {
fa[fy]=fx;
// cout<<"fx="<<fx<<" fy="<<fy<<endl;
cnt[fx]+=cnt[fy];
return true;
}
}

int check(int x){
// cout<<"fa="<<find(x)<<endl;
return cnt[find(x)];
}




int main(){
ios::sync_with_stdio(false);
while(cin>>t)
while(t--){
cin>>n;
init();
string a,b;
int ccnt=0;
rep(i,0,n){
cin>>a>>b;
if(!mmp.count(a)) mmp.insert(mp(a,++ccnt));
if(!mmp.count(b)) mmp.insert(mp(b,++ccnt));
merge(mmp[a],mmp[b]);
cout<<check(mmp[b])<<endl;

}
}
}

收获与反思

  • 可利用unordered_map加速
  • 并查集知识🔗待补充。