【HDU-1829】解题报告(带权并查集)

原始题目

A Bug's Life

  • Time Limit: 15000/5000 MS (Java/Others)
  • Memory Limit: 32768/32768 K (Java/Others)
  • Total Submission(s): 20239
  • Accepted Submission(s): 6472

Problem Description

  • Background

    Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.

  • Problem

    Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

Source

TUD Programming Contest 2005, Darmstadt, Germany

Recommend

linle

题目大意

一种虫子具有两种性别,如果假定虫子只跟异性交配,给出交配的虫子号码,判断是否符合假设(即是否存在 同性交配的虫子)。

解题思路

  • 二元关系的带权并查集(或者称之为二元种类并查集)

解题代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<iomanip>
#include<set>
#include<queue>
#include<unordered_map>
#include<string>
#include<sstream>
using namespace std;
const int maxn=1e5+5;
const int maxm=1e5+5;
const int maxl=26;

typedef long long ll;
typedef unsigned long long ull;
typedef vector<int> vi;
typedef pair<int, int> pii;
typedef pair<string,string> pss;

#define rep(i,a,n) for(int i=a;i<n;++i)
#define per(i,a,n) for(int i=n-1;i>=a;--i)
#define fi first
#define se second
#define pb push_back
#define np next_permutation
#define pb push_back
#define INF 0x3f3f3f3f
#define EPS 1e-8

int fa[maxn],cnt[maxn],relate[maxn];


int n,t,m;
void init(){
rep(i,0,maxn){
fa[i]=i;
cnt[i]=1;
relate[i]=0;
}
}


int find(int x){
if(x==fa[x]) return x;
else{
int temp=fa[x];
fa[x]=find(fa[x]);
relate[x]=(relate[x]+relate[temp])%2;
return fa[x];
}
}
int flag;
bool merge(int x,int y){
int fx=find(x);
int fy=find(y);
if(fx==fy){
//已有关系
return relate[x]==relate[y];
}
else{
fa[fx]=fy;
int temp=(1+relate[y])%2;
relate[fx]=(temp+2-relate[x])%2;
return false;
}
}


int main(){
scanf("%d",&t);
rep(j,1,t+1){
init();
scanf("%d%d",&n,&m);
flag=false;
int a,b;
rep(i,0,m){
scanf("%d%d",&a,&b);
if(flag) continue;
flag = merge(a,b);
}
printf("Scenario #%d:\n",j);
if(flag) printf("Suspicious bugs found!\n");
else printf("No suspicious bugs found!\n");
printf("\n");
}
}

收获与反思

  • 手敲并查集和带权并查集,注意输出格式,PE了两次。