【POJ-1654】解题报告(计算几何,longlong)

原始题目

Area

  • Time Limit: 1000MS
  • Memory Limit: 10000K
  • Total Submissions: 21457
  • Accepted: 5826

Description

You are going to compute the area of a special kind of polygon. One vertex of the polygon is the origin of the orthogonal coordinate system. From this vertex, you may go step by step to the following vertexes of the polygon until back to the initial vertex. For each step you may go North, West, South or East with step length of 1 unit, or go Northwest, Northeast, Southwest or Southeast with step length of square root of 2.

For example, this is a legal polygon to be computed and its area is 2.5:

Input

The first line of input is an integer t (1 ≤ t ≤ 20), the number of the test polygons. Each of the following lines contains a string composed of digits 1-9 describing how the polygon is formed by walking from the origin. Here 8, 2, 6 and 4 represent North, South, East and West, while 9, 7, 3 and 1 denote Northeast, Northwest, Southeast and Southwest respectively. Number 5 only appears at the end of the sequence indicating the stop of walking. You may assume that the input polygon is valid which means that the endpoint is always the start point and the sides of the polygon are not cross to each other.Each line may contain up to 1000000 digits.

Output

For each polygon, print its area on a single line.

Sample Input

4
5
825
6725
6244865

Sample Output

0
0
0.5
2

Source

POJ Monthly--2004.05.15 Liu Rujia@POJ

题目大意

  • 在二维坐标系中点向8个方向移动,经过一系列移动后回到原点,并且边不相交(构成闭合的多边形),求其面积。

解题思路

  • 由于坐标都是整数且很大,由于精度考虑,按照long long计算最后再除以2.

解题代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
//计算几何模板,二维几何基础
//使用印用注意避免直接在程序中调用构造函数构造无名对象。否则可能会导致程序出错
//#include <bits/stdc++.h>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <set>
#include <iomanip>
#include <algorithm>
#include <queue>
#include <map>
#include <string>
#define INF 0x3f3f3f3f
#define rep(i,a,n) for(int i=a;i<n;i++)
#define per(i,a,n) for(int i=n-1;i>=a;i--)
using namespace std;
typedef long long ll;
const double eps =1e-10;
const int maxn=50;
int n;
//有的命名为sgn函数,高精度符号判断
int dcmp(double x){
//相等函数判断,减少精度问题
if(fabs(x)<eps) return 0;
else return x<0?-1:1;
}

//点的定义
class Point{
public:
ll x,y;
Point (ll x=0,ll y=0):x(x),y(y){} //构造函数,方便代码的编写
};

typedef Point Vector;// 从程序实现上,Vector只是Point的别名

//运算符重载
//向量+向量=向量,点+向量=点
Vector operator + (const Vector &A,const Vector &B) { return Vector(A.x+B.x,A.y+B.y); }
//向量-向量=向量,点-向量-点
Vector operator - (const Vector &A,const Vector &B) { return Vector(A.x-B.x,A.y-B.y); }
//向量*数=向量 (数乘)
Vector operator * (const Vector &A,double p) { return Vector(A.x*p,A.y*p); }
//向量/数=向量 (数除)
Vector operator / (const Vector &A,double p) { return Vector(A.x/p,A.y/p); }
//向量(点乘)向量=数 (点乘)
double operator * (const Vector &A,const Vector &B) { return A.x*B.x+A.y*B.y; }
double dot(const Vector &A,const Vector &B){ return A.x*B.x+A.y*B.y; }
//向量(叉乘)向量=向量 (叉乘)
double operator ^ (const Vector &A,const Vector &B){ return A.x*B.y-A.y*B.x; }
ll cross(const Vector &A,const Vector &B){ return A.x*B.y-A.y*B.x; }
//计算向量模长
double abs(const Vector &A){ return sqrt(dot(A,A));}
//计算平行四边形方向面积
double area2(const Point &A,const Point &B,const Point &C){ return cross(B-A,C-A) ;}

//按x值递增排序
bool operator < (const Point &A,const Point &B) { return A.x==B.x?A.y<B.y:A.x<B.x; }

//判定两个点是否相同,用到dcmp精度判定
bool operator == (const Point &A,const Point &B) { return dcmp(A.x-B.x)==0&& dcmp(A.y-B.y)==0; }

//向量旋转
Vector rotate(Vector A,double rad) { return Vector(A.x*cos(rad)-A.y*sin(rad),A.x*sin(rad)+A.y*cos(rad));}
//计算单位法线,左转90
Vector normal(Vector A){
double l=abs(A);
return Vector(-A.y/l,A.x/l);
}

//线段定义
class Line {
public:
Point s,e;
Line(){}
Line(Point _s,Point _e){
s=_s;e=_e;
}

}line[maxn];
//判断两线段是否相交
bool inter(Line l1,Line l2){
// cout<<"L1 "<<l1.e.x<<","<<l1.e.y<<" "<<l1.s.x<<","<<l1.s.y<<endl;
// cout<<"L2 "<<l2.e.x<<","<<l2.e.y<<" "<<l2.s.x<<","<<l2.s.y<<endl;
return (
//根据题目要求端点相交是否算作相交来决定大于等于和小于等于
//排斥实验
max(l1.s.x,l1.e.x)>=min(l2.s.x,l2.e.x) &&
max(l2.s.x,l2.e.x)>=min(l1.s.x,l1.e.x) &&
max(l1.s.y,l1.e.y)>=min(l2.s.y,l2.e.y) &&
max(l2.s.y,l2.e.y)>=min(l1.s.y,l1.e.y) &&
//跨立实验
dcmp((l2.s-l1.s)^(l1.s-l1.e))*dcmp((l2.e-l1.s)^(l1.s-l1.e))<0 &&
dcmp((l1.s-l2.s)^(l2.s-l2.e))*dcmp((l1.e-l2.s)^(l2.s-l2.e))<0
) ;
}
bool inter(Point a1,Point a2,Point b1,Point b2){
Line l1(a1,a2),l2(b1,b2);
return inter(l1,l2);
}

//求两直线交点
Point getinter(Line l1,Line l2){
Vector v=l1.s-l1.e;
Vector w=l2.s-l2.e;
Vector u=l1.e-l2.e;
double t=cross(w,u)/cross(v,w);
return l1.e+v*t;
}
Point getinter(Point a1,Point a2,Point b1,Point b2){
Line l1(a1,a2);
Line l2(b1,b2);
return getinter(l1,l2);
}


//判定点和线段的关系,
//0:不在线段所在直线上
//1:在线段内(不含端点)
//2:在线段端点
//3:在线段两侧的射线上
int online(Point a,Line l){
if(dcmp(cross(l.s-a,l.e-a))!=0) return 0;
double pans=dcmp(dot(l.s-a,l.e-a));
// cout<<(l.s-a).x<<","<<(l.s-a).y<<" "<<(l.e-a).x<<","<<(l.e-a).y<<endl;
if(pans<0) return 1;
else if(pans==0) return 2;
else if(pans>0) return 3;
}
int online(Point a,Point b1,Point b2){
Line l(b1,b2);
return online(a,l);
}



int main(){
int t;
cin>>t;
while(t--){
Point pnow(0,0),pnext(0,0);
ll area=0;
string s;
cin>>s;
int len=s.size();
rep(i,0,len){
pnow=pnext;
switch(s[i]){
case '8': pnext.y++; break;
case '2': pnext.y--; break;
case '6': pnext.x++; break;
case '4': pnext.x--; break;
case '9': pnext.x++, pnext.y++; break;
case '7': pnext.x--, pnext.y++; break;
case '3': pnext.x++, pnext.y--; break;
case '1': pnext.x--, pnext.y--; break;
default: break;

}
area+=cross(pnext,pnow);
}
area=(area<0?(0-area):area);
if(area%2==0) cout<<area/2<<endl;
else cout<<area/2<<".5"<<endl;
}
}

收获与反思

  • 整数坐标注意开long long。
  • 多边形有向面积模板题。